Skip to main content
Asked a question 6 years ago

How do I enable a graphical (X11) login after installation?

Where am I?

In Bright Computing, Inc. you can ask and answer questions and share your experience with others!

Why Is The SLES Graphical Console Disabled After Installation?
 

After the Bright head node installation for SLES, the Graphical console option is disabled. This is because it requires a manual X configuration with the sax2 utility for certain hardware, and does not work out of the box for all hardware. 

Installing And Enabling the SLES Graphical Console After Installation

However, it is still possible to install and enable, for example, the Gnome Graphical desktop environment after the installation of a Bright head node, using the following recipe:

For Head Node

1.  Install Gnome X packages

     % yast -i

     Filter based on 'Patterns'. This will provide a list of group install packages. Select Gnome

2. Edit /etc/inittab and change default runlevel to 5.

    id:5:initdefault:

3. Edit /etc/sysconfig/displaymanager

    DISPLAYMANAGER="gdm"

4. Run sax2 (this is a graphical utility)

Make sure your screens, mouse, keyboard, etc are detected. Save the configuration and quit the utility

5. Reboot

For Compute Nodes

Assuming that the software image for your nodes is  /cm/images/default-image

mount -o bind /proc /cm/images/default-image/proc
mount -o bind /sys /cm/images/default-image/sys
chroot /cm/images/default-image
Repeat Steps 1 to 5 above.

Disable NetworkManager

NetworkManager must be disabled to prevent interference with the network management provided by the cluster manager.

On SLES11, it can be disabled using YAST2.

On Red Hat 6 and derivatives, disabling can be done like:
[root@bright70 ~]# service NetworkManager status
NetworkManager (pid 1527) is running...
[root@bright70 ~]# chkconfig NetworkManager off
[root@bright70 ~]# service NetworkManager stop


On Red Hat 7 and derivatives:
[root@bright70 ~]# systemctl status NetworkManager.service
[root@bright70 ~]# systemctl disable NetworkManager.service