Skip to main content
Ask Question
General
Asked a question 4 years ago

The node-installer fails to detect the bridge interfaces after upgrading to RHEL/CentOS 7.3

Where am I?

In Bright Computing, Inc. you can ask and answer questions and share your experience with others!

In recent (As of December 2016) versions of RHEL/CentOS 7.3, the bridge kernel module has been split into two components: the bridge and br_netfilter kernel modules. By default, Bright adds the bridge kernel module to the list of kernel modules in any software image. After upgrading a software image to RHEL/CentOS 7.3, the kernel gets updated to version 3.10.0-514.2.2.el7.x86_64 in which the bridge kernel module has been split, any compute node with a bridge interface will fail to boot with the following error message:

 

Dec 15 13:29:37 148.187.81.15 node-installer: Can't open directory '/proc/sys/net/bridge/'.

Dec 15 13:29:37 148.187.81.15 node-installer: There was a fatal problem. This node can not be installed until the problem is corrected.

Dec 15 13:29:37 148.187.81.15 node-installer: The error was: The 'bridge' kernel modules is not loaded. Please add 'bridge' kernel module to softwareimage kernelmodules.

Dec 15 13:29:37 148.187.81.15 node-installer: Updating device status: The 'bridge' kernel modules is not loaded. Please add 'bridge' kernel module to softwareimage kernelmodules.

 

To fix this issue, the br_netfilter kernel module needs to be added:

 

# cmsh

% softwareimage use default-image

% kernelmodules

% add br_netfilter

% commit

(wait until the initrd is generated)

 

The "default-image" can be set to a new software image name. This new name can then be used for the image used by the compute nodes with the bridge interfaces.